PostgreSQL: Beveiligingswaarschuwing over verschillende IT-kwetsbaarheden

Algemeen

Er is een IT-beveiligingswaarschuwingsupdate uitgebracht voor een bekende kwetsbaarheid voor PostgreSQL. U kunt hier een beschrijving van de beveiligingslekken lezen, inclusief de nieuwste updates en informatie over de getroffen besturingssystemen en producten.

Op 16 april 2024 bracht het Federale Bureau voor Informatietechnologie (BSI) een update uit voor een beveiligingslek met verschillende kwetsbaarheden voor PostgreSQL dat op 10 augustus 2023 bekend werd. Het beveiligingsprobleem treft de besturingssystemen Linux, UNIX en Windows, evenals de producten Debian Linux, Amazon Linux 2, Red Hat Enterprise Linux, Ubuntu Linux, SUSE Linux, Oracle Linux, Open Source PostgreSQL en Broadcom Brocade SANnav.

De nieuwste aanbevelingen van de fabrikant met betrekking tot updates, oplossingen en beveiligingspatches voor dit beveiligingslek vindt u hier: (vanaf 16 april 2024). Andere nuttige bronnen vindt u verderop in dit artikel.

Meerdere kwetsbaarheden voor PostgreSQL – Risico: gemiddeld

Risiconiveau: 4 (gemiddeld)
CVSS-basisscore: 7,5
CVSS tijdelijke score: 6,5
Afstandsbediening: Ja

Het Common Vulnerability Scoring System (CVSS) wordt gebruikt om de ernst van kwetsbaarheden in computersystemen te beoordelen. De CVSS-standaard maakt het mogelijk om potentiële of feitelijke beveiligingskwetsbaarheden te vergelijken op basis van verschillende statistieken om zo een prioriteitenlijst op te stellen voor het nemen van tegenmaatregelen. De attributen “geen”, “laag”, “medium”, “hoog” en “kritiek” worden gebruikt om de ernstniveaus van een kwetsbaarheid te bepalen. De Basisscore evalueert de vereisten voor een aanval (inclusief authenticatie, complexiteit, privileges, gebruikersinteractie) en de gevolgen ervan. De temporele score houdt ook rekening met veranderingen in de tijd in de gevaarsituatie. Volgens de CVSS wordt de ernst van de huidige kwetsbaarheid beoordeeld als “medium” met een basisscore van 7,5.

PostgreSQL-bug: samenvatting van bekende kwetsbaarheden

PostgreSQL is een gratis beschikbare database voor verschillende besturingssystemen.

Een op afstand geverifieerde aanvaller kan meerdere kwetsbaarheden in PostgreSQL misbruiken om willekeurige code uit te voeren of beveiligingsmaatregelen te omzeilen.

De kwetsbaarheid wordt geïdentificeerd met de unieke CVE-identificatienummers (Common Vulnerabilities and Exposures). CVE-2023-39417 en CVE-2023-39418 verhandeld.

Systemen die getroffen zijn door de PostgreSQL-kwetsbaarheid in één oogopslag

Besturingssystemen
Linux, UNIX, Windows

Producten
Debian Linux (cpe:/o:debian:debian_linux)
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
SUSE Linux (cpe:/o:suse:suse_linux)
Oracle Linux (cpe:/o:oracle:linux)
Open Source PostgreSQL <15.4 (cpe:/a:postgresql:postgresql)
Open source PostgreSQL <14.9 (cpe:/a:postgresql:postgresql)
Open source PostgreSQL <14.9 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL <13.12 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL <13.12 (cpe:/a:postgresql:postgresql)
Open source PostgreSQL <12.16 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL <12.16 (cpe:/a:postgresql:postgresql)
Open source PostgreSQL <11.21 (cpe:/a:postgresql:postgresql)
Open source PostgreSQL <11.21 (cpe:/a:postgresql:postgresql)
Broadcom Brocade SANnav <2.3.1 (cpe:/a:broadcom:brocade_sannav)
Broadcom Brocade SANnav <2.3.0a (cpe:/a:broadcom:brocade_sannav)

Algemene maatregelen voor het omgaan met IT-kwetsbaarheden

  1. Gebruikers van de getroffen applicaties moeten deze up-to-date houden. Wanneer gaten in de beveiliging bekend worden, zijn fabrikanten verplicht deze zo snel mogelijk op te lossen door een patch of een tijdelijke oplossing te ontwikkelen. Als er nieuwe beveiligingsupdates beschikbaar zijn, installeer deze dan onmiddellijk.
  2. Raadpleeg voor informatie de bronnen in het volgende gedeelte. Deze bevatten vaak meer informatie over de nieuwste versie van de betreffende software, de beschikbaarheid van beveiligingspatches of tips voor oplossingen.
  3. Als u nog vragen of onduidelijkheden heeft, kunt u contact opnemen met uw verantwoordelijke beheerder. IT-beveiligingsmanagers moeten regelmatig controleren wanneer het productiebedrijf een nieuwe beveiligingsupdate beschikbaar stelt.

Bronnen van updates, patches en oplossingen

Hier vindt u verdere links met informatie over bugrapporten, beveiligingsoplossingen en tijdelijke oplossingen.

Brocade Security Advisory BSA-2023-2371 vom 2024-04-16 (16.04.2024)
Voor meer informatie, zie:

Red Hat Security Advisory RHSA-2024:0337 vom 2024-01-24 (23.01.2024)
Voor meer informatie, zie:

Red Hat Security Advisory RHSA-2024:0332 vom 2024-01-23 (22.01.2024)
Meer…

Buitenlands nieuws
Add a comment